Chapitre :

Fonctions prédéfinies

De très nombreuses fonctions sont prévues dans Excel.
Elles permettent de faire des calculs qui demanderaient la saisie fastidieuse de formules souvent complexes.

Appeler une fonction

outil somme automatique

Il vous est toujours possible, si vous connaissez parfaitement la syntaxe de la fonction, de rédiger son appel par écrit en la tapant directement dans la barre de formule.

Sinon il reste 3 possibilités :

Certaines fonctions demandent un ou des arguments.

Arguments de la fonction

Saisir les références ou cliquer sur les cellules qui contiennent les arguments
Valider par [OK]
La formule aurapar exemple l'allure suivante :    =SOMME(B16:D16;100)
Le nom de la fonction est suivi de deux parenthèses qui contiennent la liste des arguments séparés par des points-virgules.

 

Syntaxe

NOM_DE_LA_FONCTION( argument 1 ; argument 2 ; …)

Le nom de la fonction est un seul mot (sans espaces) et s’écrit en majuscules.

Il est suivi de deux parenthèses.

Ces parenthèses contiennent au besoin un ou des arguments qui peuvent êtres des valeurs constantes (telles que des nombres ou des chaînes de caractères), des références à d’autres cellules ou des expressions qui contiennent à leur tour d’autres fonctions.

Lorsqu’il y a plusieurs arguments, ceux-ci sont séparés par des points-virgules.

Pensez à activer la touche F4 si les références doivent être absolues ou mixtes.

Quelques fonctions courantes

SOMME( nombre1 ; nombre2 ; …)     Rend la somme des arguments numériques de la fonction.

MOYENNE( nombre1 ; nombre2 ; …)     Calcule la moyenne des arguments numériques.

MAX( nombre1 ; nombre2 ; …)     Rend la valeur le nombre le plus grand.

MIN( nombre1 ; nombre2 ; …)     Rend la valeur minimale d'une liste de nombres.

ARRONDI( nombre_à_arrondir, nombre_de_décimales)     Donne l'arrondi.

MOD( nombre, diviseur)     Renvoie le reste de la division entière.

PUISSANCE( nombre ; puissance)     Rend nombre puissance.

RACINE( nombre)     Donne la racine carrée d'un nombre.

 

Dans la catégorie "Fonctions logiques"

SI( condition ; valeur_si_vrai ; valeur_si_faux)     Valeur rendue dépend du test de la condition.

ET(valeur_logique1 ; valeur_logique2, …)     = VRAI si tous les arguments sont VRAI

NON( valeur_logique)    Inverse la valeur logique de l'argument

OU( valeur_logique1 ; valeur_logique2 ; …)     Rend VRAI si l'un des argument est VRAI

 

Dans la catégorie "Date & Heure"

AUJOURDHUI()   = la date d'aujourd'hui

MAINTENANT()    idem avec l'heure en plus

JOUR()   donne le jour du mois (un nombre entre 1 et 31)

 

Dans la catégorie "Texte"

LIEN_HYPERTEXTE( emplacement, nom_convivial)

Crée un raccourci pour ouvrir un document sur votre PC, votre réseau ou sur Internet.

MAJUSCULE( texte)   Convertit une chaîne de caractères en majuscules.

MINUSCULE( texte)  Convertit une chaîne de caractères en minuscules.

NBCAR( texte)   Renvoie le nombre de caractères.


XHTML	1.0	validé! CSS validé!